How can we improve SandDance?

Time and date coded data is not properly handled

Awesome tool. Thanks.
I have 4 days of data with 24 hourly event data in each day. After importing the data set I am expecting to see four columns each with 24 data points. Instead I see three columns. One with 48 data points and the remaining two with 24. No matter what kind of analysis is done afterwards, this strange grouping of dates persists. How can I get SandDance to treat each days event data confined to that day during the analysis?

2 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    3 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        Steven, Thank you for a very quick reply. Both of these w/a did not work. In fact, DataScrubber properly recognizes the Date column as Date. Try importing this. For me this data set produces 5 columns with the second one empty. Even if x axis bin are set to 4
        DATE,HR,KIWI,APPLE,PEAR,GRAPE
        3/14/2016,0,11,382,691,820
        3/14/2016,1,31,334,579,817
        3/14/2016,2,21,303,637,815
        3/14/2016,3,19,384,634,860
        3/14/2016,4,28,312,528,857
        3/15/2016,0,26,324,643,807
        3/15/2016,1,47,287,535,938
        3/15/2016,2,32,260,641,846
        3/15/2016,3,18,261,641,917
        3/15/2016,4,50,400,554,908
        3/16/2016,0,18,276,517,996
        3/16/2016,1,45,353,533,856
        3/16/2016,2,14,282,697,897
        3/16/2016,3,10,360,565,900
        3/16/2016,4,22,247,653,902
        3/17/2016,0,47,337,613,819
        3/17/2016,1,20,308,688,879
        3/17/2016,2,28,230,652,965
        3/17/2016,3,45,266,631,903
        3/17/2016,4,14,263,683,817

      • Steven Drucker commented  ·   ·  Flag as inappropriate

        We're still working on effective autodetection of number formats. There's a tool available in the 'settings' menu called the 'DataScrubber' (look in the IconBar settings). This allows specifying what format is appropriate for a particular column and you should be able to force that column to be a date format. As a workaround for now, you can additionally force the number of bins for a column with the bin slider at the bottom to be 4.

      Feedback and Knowledge Base